Error: The submitted form was invalid

Forum Resource Management & Use (Policy, How To Post)

Moderators: OpenUru.org Moderators, Domain Managers

Post Reply
User avatar
Mac_Fife
Member
Posts: 1229
Joined: Fri Dec 19, 2008 12:38 am
Location: Scotland
Contact:

Error: The submitted form was invalid

Post by Mac_Fife » Sat Sep 22, 2012 9:24 pm

From another thread:
CalumTraveler wrote:Minor offtopic rant:
SpoilerShow
(Oh. My GOD. Come On. I've been trying to post this one simple post for THREE HOURS NOW. Why is everything just fighting me this month?!) Stop giving me "The submitted form was invalid. Try submitting again" I'm getting tired of this stupid message every time I try to submit it!
I don't know why this might be happening. This error usually happens when either a) the forum software (phpBB) gets updated and some file got missed or b) the forum style isn't matched to the version of phpBB. However, neither of those are the case here as what we're running has been in place and stable for several months.

Basically, for anything that changes the database, there's a check that the correct form is being used, e.g. if it's a "posting" operation that it isn't using the form for updating your preferences. That's already all taken care of so it should never really happen. But I guess there could be an issue if you've got a stale session cookie or something cached in the browser. It'd be interesting to know if it happens again.
Mac_Fife
OpenUru.org wiki wrangler

User avatar
Hoikas
Member
Posts: 286
Joined: Fri Jun 03, 2011 8:38 pm

Re: Error: The submitted form was invalid

Post by Hoikas » Sun Sep 23, 2012 5:23 am

The style must have an error in it. They change from bugfix release to bugfix release. I've seen plenty of styles designed for older versions of phpBB 3.0.x fail on phpBB 3.0.Y where Y > X.
Image

User avatar
Mac_Fife
Member
Posts: 1229
Joined: Fri Dec 19, 2008 12:38 am
Location: Scotland
Contact:

Re: Error: The submitted form was invalid

Post by Mac_Fife » Sun Sep 23, 2012 6:30 pm

That's certainly one of the most common explanations for this type of error, but I've (I think) kept the forum style pretty tightly aligned with the phpBB revisions. I usually wait until the base style is updated for the current version then re-tailor it for OU, and then test it out on another server before it gets deployed here. This is the first anyone has mentioned having this problem and the current version (3.0.10) has been in place since the end of June, which is why I'm interested to know if there are other instances.

However, we do have 3.0.11 ready to roll out anyway, when time permits (but I'll maybe do some additional testing of that now).
Mac_Fife
OpenUru.org wiki wrangler

User avatar
D'Lanor
Member
Posts: 142
Joined: Tue Dec 23, 2008 11:23 pm

Re: Error: The submitted form was invalid

Post by D'Lanor » Sun Sep 23, 2012 6:59 pm

Does it happen just with the openuru style or with prosilver and subsilver as well?

User avatar
Mac_Fife
Member
Posts: 1229
Joined: Fri Dec 19, 2008 12:38 am
Location: Scotland
Contact:

Re: Error: The submitted form was invalid

Post by Mac_Fife » Sun Sep 23, 2012 7:31 pm

I've tried all three and have been unable to replicate CalumTraveler's issue :? . I've also tried FireFox, IE and Safari browsers and I know JW uses Chrome and rarified uses Opera.
Mac_Fife
OpenUru.org wiki wrangler

Post Reply

Return to “Forums (phpBB)”

Who is online

Users browsing this forum: No registered users and 1 guest