Python 2.3 dependencies?

Open: Collect Technical Information Regarding Building And Testing Uru

Moderator: Building & Testing Managers

Post Reply
User avatar
rarified
Member
Posts: 800
Joined: Tue Dec 16, 2008 10:48 pm
Location: Colorado, US

Python 2.3 dependencies?

Post by rarified » Mon Jan 26, 2009 4:00 pm

Does anybody know if there is a real dependency of the MOUL code upon Python 2.3?

I seem to remember reading something along those lines when I was looking at the various tools for examining age files.

Building Python 2.3 with "current" windows tools is something of a pain since MS altered the C libraries to validate all parameters "to enhance security". Py2.3 is not prepared to deal with the differences between MS and Posix (later python revisions have code to work around it).
One of the OpenUru toolsmiths... a bookbinder.

User avatar
Marten
Member
Posts: 174
Joined: Fri Dec 26, 2008 1:19 am

Re: Python 2.3 dependencies?

Post by Marten » Tue Feb 03, 2009 1:47 am

If there is a dependency on an older version of Python, then I propose the way to fix that is to update the Python code to eliminate the dependency. :D
The music is reversible, but time is not.

User avatar
rarified
Member
Posts: 800
Joined: Tue Dec 16, 2008 10:48 pm
Location: Colorado, US

Re: Python 2.3 dependencies?

Post by rarified » Tue Feb 03, 2009 2:02 am

Marten wrote:If there is a dependency on an older version of Python, then I propose the way to fix that is to update the Python code to eliminate the dependency. :D
I'd love to :)

But I'm concerned that there may be some compiled python code embedded in age files that require the older interpreter to execute properly. Or that the existing MOUL client needs a 2.3 API library to build.
One of the OpenUru toolsmiths... a bookbinder.

Post Reply

Return to “Building & Testing”

Who is online

Users browsing this forum: No registered users and 2 guests