OpenSSL "Heartbleed" vulnerability

Discussions About CyanWorlds.com Engine Client & Plugin
Post Reply
User avatar
Mac_Fife
Member
Posts: 1229
Joined: Fri Dec 19, 2008 12:38 am
Location: Scotland
Contact:

OpenSSL "Heartbleed" vulnerability

Post by Mac_Fife » Tue Apr 08, 2014 6:57 pm

Given the security advisory posted on the OpenSSL website and reported by the BBC (amongst others), I've rebuilt the openssl32 and libeay32 DLLs using the latest, fixed 1.0.1g sources (I know a few folk aren't keen to try following the instructions that OpenSSL.org provide).

It can be downloaded here: http://uru.mac-fife.me.uk/openssl-1.0.1g.zip - I've removed the old download file (1.0.1e), since it was likely affected by the vulnerability.
Mac_Fife
OpenUru.org wiki wrangler

User avatar
Hoikas
Member
Posts: 286
Joined: Fri Jun 03, 2011 8:38 pm

Re: OpenSSL "Heartbleed" vulnerability

Post by Hoikas » Wed Apr 09, 2014 12:46 am

Uru itself wasn't affected by the vulnerability... But if you're using those DLLs for something else, it's probably a good idea to upgrade.
Image

Post Reply

Return to “CyanWorlds.com Engine - Client & Plugin”

Who is online

Users browsing this forum: No registered users and 2 guests