Guidance Needed

Discussions About CyanWorlds.com Engine Client & Plugin
Post Reply
CaptainQuery
Member
Posts: 7
Joined: Sat Dec 13, 2008 2:28 am

Guidance Needed

Post by CaptainQuery » Tue Oct 27, 2015 7:33 pm

Hi. I am part of a small group that is working on an ages project. One of our group, Rocketdog, is using 3ds Max8 and has hit a stonewall with Python errors. He is currently having password issues with OU so he has asked me to relay his issue/question until he can get the pw issue resolved with you folks. He has not had much success on the GoW forums so he is hoping one of you might be able to help or get him to the right person.

Thanks!

CQ


Rocketdog writes:

I'm unable to acess my python files in 3ds Max8. I assume the files are being accessed by Max because they are showing up in the .log file but do not show up in the plasma menu. Python files “testage” and “xfogset” and a testage.pak file are the only files I have in the output\python folder. I have python version 2.2 and 2.3 installed

Image Here is a copy of the .log file
(10/25 14:48:35) Traceback (most recent call last):

(10/25 14:48:35) File ".\python\testage.py", line 2, in ?

(10/25 14:48:35) from PlasmaTypes import *

(10/25 14:48:35) File ".\python\plasma\PlasmaTypes.py", line 73, in ?

(10/25 14:48:35) kVarNumberType=PtNotifyDataType.kFloat

(10/25 14:48:35) AttributeError: 'PlasmaConstants.Enum' object has no attribute 'kFloat'

(10/25 14:48:35) Traceback (most recent call last):

(10/25 14:48:35) File ".\python\xFogSet.py", line 55, in ?

(10/25 14:48:35) FogMode = ptAttribDropDownList(1, "Fog Mode", ("Linear", "Exponential", "Exponential2"))

(10/25 14:48:35) NameError: name 'ptAttribDropDownList' is not defined

I'm using windows 7 64bit

Anyone have any Idea what's wrong from reading this log file.

User avatar
rarified
Member
Posts: 800
Joined: Tue Dec 16, 2008 10:48 pm
Location: Colorado, US

Re: Guidance Needed

Post by rarified » Tue Oct 27, 2015 9:49 pm

On first glance it looks like the Python<->C++ glue did not initialize the 'kFloat' constant in the PtNotifyDataType() Python class.

That constant is set as an enumerable element in pyNotifyGlue.cpp, and is part of the FeatureLib of the CWE Plasma sources.

Is it possible the CWE libraries referenced by Max8 are out of date or somehow incompatible with it? Does rebuilding it help?

_R
One of the OpenUru toolsmiths... a bookbinder.

rocketdog
Member
Posts: 10
Joined: Thu Apr 07, 2011 4:05 pm

Re: Guidance Needed

Post by rocketdog » Tue Oct 27, 2015 10:50 pm

rarified,

The testage.py .pyc and .pak files are new, They were just created to run the file required (according to Andy Legate) so python will work correctly in an age. We will also be adding some non-globules in these files but have not added then yet.

I will pass this on to Edisonrex and Sanguina they are the ones taking care of the python programming , if it is a programming problem.

Would you agree that Max is seeing the files if they are showing up in the .log file?

rocketdog

User avatar
rarified
Member
Posts: 800
Joined: Tue Dec 16, 2008 10:48 pm
Location: Colorado, US

Re: Guidance Needed

Post by rarified » Tue Oct 27, 2015 10:56 pm

rocketdog wrote:...
Would you agree that Max is seeing the files if they are showing up in the .log file?

rocketdog
Yes, Max (through it's Python Interpreter) is seeing the files. What's more... It is also seeing the python scripting code from CWE. So that part of the setup is good. It is strange that only that particular constant is not found, which is why I wondered about an out of date CWE build (or one compiled by a version of C++/Python that is not compatible with Max8).

_R
One of the OpenUru toolsmiths... a bookbinder.

rocketdog
Member
Posts: 10
Joined: Thu Apr 07, 2011 4:05 pm

Re: Guidance Needed

Post by rocketdog » Tue Oct 27, 2015 11:21 pm

rarified,

How can I tell which version of the CWE I am using?

I did have the python files showing up in the plasma drop down on my old computer using Max8 and I believe I have the same CWE installed as I did in the past. In fact I think it is the original Cyan Worlds release engine I am using. I do know that the original engine worked on Max7 and 8. Will the new CWE work with all Max versions? I thought they were just for the newer versions of Max.

rocketdog

I just looked and found this. I'm sure these are the same plasmaMax files I had in my other computer.

These files (MaxPlasmaLights.dlo and PlasmaMax.gup) are the binary plugins that go with MOULagain build 871 (they may work on future builds as well).
These plugins were built for 3ds Max version 7. Place them in the C:\3dsmax7\plugins directory.
Please use legal copies of 3ds Max version 7.

User avatar
Hoikas
Member
Posts: 286
Joined: Fri Jun 03, 2011 8:38 pm

Re: Guidance Needed

Post by Hoikas » Wed Oct 28, 2015 2:07 am

Now for some useful information...

The Python glue was changed significantly in a recent open source build of the plugin to fix some bugs that appeared on MOULa and to close several security holes. This has the unfortunate side effect of making the current MOULa Python files not work correctly with the 871 max plugin distributed by Cyan (hence the error you see in the log). You will need to either update to the 917 plugins (which I don't think have been posted anywhere publically) or downgrade your python files to a version without these fixes, which can be found here. Note that using these files will not make your age or computer insecure--the fixes are only relevant when running the full game. I made a fake game folder with those Python files and a "dat" folder to export into--don't paste them over your game files! This was how I got Vothol Gallery to reexport before we got the 917 plugins ;)

Also, make sure that your age's python files are unpacked if you want to use them in max ;).

PS You're very lucky I saw this. I usually check this forum about once every week-and-a-half. Posting on the GoW forum will get you a response from someone who remembers basically all of the changes in two different forks of the engine.

PPS I rattled the hive about getting those 917 plugins out.
Image

rocketdog
Member
Posts: 10
Joined: Thu Apr 07, 2011 4:05 pm

Re: Guidance Needed

Post by rocketdog » Wed Oct 28, 2015 1:36 pm

Hoikas,

Thanks, I'll give that a try. And let you two know if that fixes the problem.

By the way I posted here because in the past I had a problem with python and no one was able to help me on the GoW. Anyway I did get it to work last time but I never did know what made it start working.

rocketdog

rocketdog
Member
Posts: 10
Joined: Thu Apr 07, 2011 4:05 pm

Re: Guidance Needed

Post by rocketdog » Wed Oct 28, 2015 2:27 pm

Hoikas and rarified

Thank you both for the help.

That was it the CWE was the problem I downloaded script 893 installed it and......... I CAN SEE MY PYTHON FILES ..........in the plasma drop down!!!

rocketdog

User avatar
Hoikas
Member
Posts: 286
Joined: Fri Jun 03, 2011 8:38 pm

Re: Guidance Needed

Post by Hoikas » Mon Nov 02, 2015 3:15 am

Glad to hear it's working :)

I try to avoid giving advice about specific python script problems (ie puzzle/age logic) because Uru python is extremely complex. I feel like all I can do is ask thousands of stupid questions unless I have the age and the code in front of me--and I don't need another iron in the fire ;). I certainly can help with initial setup things like this though, but sometimes I just don't see it in a timely manner or just forget to respond when I do :(. My students know the best way to get me to help them is to keep pestering me :lol:
Image

Post Reply

Return to “CyanWorlds.com Engine - Client & Plugin”

Who is online

Users browsing this forum: No registered users and 1 guest