Testing an XP-compatible H'uru build

Discussions About CyanWorlds.com Engine Client & Plugin
Post Reply
Marein
Member
Posts: 5
Joined: Sat Feb 13, 2016 9:28 pm

Testing an XP-compatible H'uru build

Post by Marein » Mon Feb 15, 2016 10:24 am

This thread is a continuation of my posts here. I thought it might be better to create a new topic just for this.

Turned out I was crashing Gehn earlier by attempting to log in with a wrong Build ID. I'm now testing on Destiny.

Again, I'm using the VS 2013 Windows XP compiler to build the game, and running it in a Windows XP VM. The game starts, showing the initial loading screen, and then presents the 'create account' screen, but it's not complete, see below. I can input the explorer name and gender (I can select both genders at the same time), and the invitation code, but the 'buttons' below are non-interactable (no dot in cursor). I thought the interactive area might be displaced to somewhere else on the screen, but that doesn't seem to be the case. Pressing enter also does nothing (I don't know if it's supposed to though).

Image

Does this maybe look familiar? Could there be something wrong with my build, or the way I set up the game folder? I used the materials as specified on the Destiny forum. I'm using -LocalData.

Marein
Member
Posts: 5
Joined: Sat Feb 13, 2016 9:28 pm

Re: Testing an XP-compatible H'uru build

Post by Marein » Mon Feb 15, 2016 11:24 am

I copied the dat folder over from the Gehn installation (rather than using the MOULa dat folder as suggested in the Destiny documentation) and now it's working. I went through Relto, hood, Gahreesen, city and tested some KI features. The XP-compiled build seems to be working. At least in my VM.

User avatar
Mac_Fife
Member
Posts: 1227
Joined: Fri Dec 19, 2008 12:38 am
Location: Scotland
Contact:

Re: Testing an XP-compatible H'uru build

Post by Mac_Fife » Mon Feb 15, 2016 8:53 pm

OK, that means that, in principle, a H'uru based client is feasible, adding a level of "proof" to the comments made by Hoikas in response to Christian's original post. That's good, but I think I'd like to understand why Ghen's data rather than "standard" MOULa data was needed, though I suspect it's maybe related to having built a "Ghen client" rather than one that was specifically targeted for MOULa - At least, that's what I take from a quick re-parsing of Hoikas post.
Mac_Fife
OpenUru.org wiki wrangler

Marein
Member
Posts: 5
Joined: Sat Feb 13, 2016 9:28 pm

Re: Testing an XP-compatible H'uru build

Post by Marein » Mon Feb 15, 2016 10:29 pm

I don't know enough about the workings of the client to answer this. I can only guess that it's caused by the H'uru avatar-creation interface relying on resources (textures etc) that are absent in MOULa, hence it fails to build the interface properly if only the MOULa resources are present. But someone else may have a better idea about this.

Also note that I never used this client to log in to MOULa, only to Gehn and Destiny. So having built it for Gehn/Destiny instead of MOULa should be the correct course of action.

User avatar
Hoikas
Member
Posts: 284
Joined: Fri Jun 03, 2011 8:38 pm

Re: Testing an XP-compatible H'uru build

Post by Hoikas » Tue Feb 16, 2016 2:07 am

I think it's a data corruption issue, not a client problem--H-uru clients work just fine against MOULa data on my machine. The only difference the XP toolchain does is downgrade the Windows SDK to version 7.
Image

jamie marchant
Member
Posts: 21
Joined: Wed May 04, 2011 5:13 pm
Contact:

Re: Testing an XP-compatible H'uru build

Post by jamie marchant » Tue Jun 07, 2016 10:23 pm

If you still have this issue it could be the VM. Last I checked, some of them only have 'beta' 3D acceleration drivers.

Post Reply

Return to “CyanWorlds.com Engine - Client & Plugin”

Who is online

Users browsing this forum: No registered users and 1 guest