Installing MOSS

Discussions About MOSS (Myst Online Server Software)

Moderator: a'moaca'

User avatar
Lyrositor
Member
Posts: 156
Joined: Sun Feb 05, 2012 10:58 pm
Contact:

Installing MOSS

Post by Lyrositor » Sun Feb 12, 2012 3:40 am

Shorah. I've been trying to install MOSS and so far I'm a bit confused. I have a few questions which I think should be able to put in the right direction:
1. Where is MOSS installed after running make install? Is it in the downloaded source directory, or somewhere else in the filesystem? Edit 1: found it in /usr/local/bin.
2. global_sdl_manager doesn't seem to work, says he can't find libmoss.so.0. Any help? Edit 2: I've found the file in /usr/local/lib. Now what?Edit 3: the one in support seems to work, I'll go with that one. Edit 4: got it working appropriately by installing elsewhere.
3. Where are all the files (auth, bin, file, game, etc.) to be located? So far I've been creating them in my home directory under the sub-directory moss.
4. Where is bin? Can't find it anywhere... Edit 1: found it.
5. After creating the file manifest, for the client (CyanStructure/Client/External) files, will they automatically be set to connect to this MOSS server? What do they do exactly?
6. What does "./" reference? Root directory? MOSS root directory? MOSS source root directory (from Mercurial repository clone)?
Lyrositor
Explorer #16601888
To D'ni, or not to D'ni. There is no question.
Image

User avatar
Lyrositor
Member
Posts: 156
Joined: Sun Feb 05, 2012 10:58 pm
Contact:

Re: Installing MOSS

Post by Lyrositor » Wed Feb 15, 2012 12:37 am

UPDATE: since I don't have Visual Studio 2003, I'm unable to connect to my server to test it out (so far as I can see). Also, I'm not sure my server is working : moss_backend keeps saying in the log files that the bind address is already in use ; however, I haven't touched that parameter (still localhost). What's not going right?
Lyrositor
Explorer #16601888
To D'ni, or not to D'ni. There is no question.
Image

User avatar
Lyrositor
Member
Posts: 156
Joined: Sun Feb 05, 2012 10:58 pm
Contact:

Re: Installing MOSS

Post by Lyrositor » Sat Feb 18, 2012 3:08 pm

UPDATE: That's working now (stupid error on my part). My client can now reach the server; only thing is, I keep getting in the log files "Unrecognized auth message". After reading a bit, I've tried changing my keys to MO:ULa's default keys, but that didn't help either. Now trying to figure out what went wrong...
Lyrositor
Explorer #16601888
To D'ni, or not to D'ni. There is no question.
Image

User avatar
JWPlatt
Member
Posts: 1099
Joined: Sun Dec 07, 2008 7:32 pm
Location: Everywhere, all at once

Re: Installing MOSS

Post by JWPlatt » Sat Feb 18, 2012 3:34 pm

Lyrositor wrote:UPDATE: That's working now (stupid error on my part). My client can now reach the server...
Please tell about how you fixed things so that others can learn from your experience.
Perfect speed is being there.

User avatar
Lyrositor
Member
Posts: 156
Joined: Sun Feb 05, 2012 10:58 pm
Contact:

Re: Installing MOSS

Post by Lyrositor » Sat Feb 18, 2012 5:06 pm

From what I can gather, it's just that the server had already been started and I couldn't restart it (I might also work on an init script to do just that eventually...).
Lyrositor
Explorer #16601888
To D'ni, or not to D'ni. There is no question.
Image

User avatar
Lyrositor
Member
Posts: 156
Joined: Sun Feb 05, 2012 10:58 pm
Contact:

Re: Installing MOSS

Post by Lyrositor » Sun Feb 19, 2012 3:55 am

UPDATE: All right, I can now login. Except I'm getting nowhere: it starts loading up files, but before reaching the char selection screen, it crashes to a stack dump. Investigating, investigating... Maybe something with Python? That's what the other threads talk about...
Lyrositor
Explorer #16601888
To D'ni, or not to D'ni. There is no question.
Image

User avatar
Lyrositor
Member
Posts: 156
Joined: Sun Feb 05, 2012 10:58 pm
Contact:

Re: Installing MOSS

Post by Lyrositor » Sun Feb 19, 2012 2:34 pm

UPDATE: Python it was! I had to add MOULSCRIPTS to the pre-built GoW fork I was using, and then I was on my way to Uru! I can now go more or less everywhere (there appear to be a few glitches though; can't link to Ahnonay or Er'cana; sometimes the game freezes; I assume these are client problems, since all error log messages are coming from the client).
Lyrositor
Explorer #16601888
To D'ni, or not to D'ni. There is no question.
Image

Rael
Member
Posts: 13
Joined: Thu Apr 07, 2011 3:31 pm

Re: Installing MOSS

Post by Rael » Tue Feb 21, 2012 10:13 am

Just one question: what do you mean by "adding MOULSCRIPTS"? I'm having the exact same issue as you, so if you could explain me this step I'll be ready to go too, I guess :D

User avatar
Lyrositor
Member
Posts: 156
Joined: Sun Feb 05, 2012 10:58 pm
Contact:

Re: Installing MOSS

Post by Lyrositor » Tue Feb 21, 2012 12:09 pm

Sure! From what I understand, some Python scripts have to be added to your client install. These can be found by doing a repository clone of https://github.com/H-uru/moul-scripts/tree/python27 You then copy the folders over your client install (including dat apparently).

Also, I released version 0.0.2 of MOSSi. It should work now, since I realize 0.0.1 didn't work. You can download the new version here, unless you've already installed MOSS. You can download the new version here: http://uru.lyros.net/mossi/
Lyrositor
Explorer #16601888
To D'ni, or not to D'ni. There is no question.
Image

User avatar
Hoikas
Member
Posts: 286
Joined: Fri Jun 03, 2011 8:38 pm

Re: Installing MOSS

Post by Hoikas » Tue Feb 21, 2012 2:13 pm

You should really be using master instead... We dropped support for Python 2.3 because it was too much of a headache.

https://github.com/H-uru/moul-scripts
Image

Post Reply

Return to “MOSS”

Who is online

Users browsing this forum: No registered users and 1 guest